Aller au contenu

Change

Pour ceux qui auraient des freeze sous Windows avec leurs SSD Crucial


  • Veuillez vous connecter pour répondre
9 réponses à ce sujet

#1
Guest_harbringer_*

Guest_harbringer_*
  • Visiteurs
Salut à tous, je n'ai pas vu, (j'ai peut être mal cherché) sur le forum un sujet relatif à ce problème alors on ne sait jamais, je vous donne mes infos, ca peut servir.

Je viens de changer mon disque dur sur un Asus G73jw (donc chipset Intel serie 5 Sata II) par un Crucial M4.
(astuce fonctionne aussi pour le C300 et peut aussi concerner les autres)

Au bout de quelques minutes d'utilisation, mon pc se fige pendant 30 secondes voir plus, et reprend comme si de rien n'était.

Le symptôme principal pour savoir si vous êtes concerné est le suivant.
Allez dans le journal des évènements, et vous verrez une erreur iaStor 9 dans le journal.
"Le périphérique n'a pas répondu dans les délais impartis" quelque chose dans le genre :)

Avant de vouloir désactiver l'AHCI comme j'ai pu le lire par ci par là, faites la manip que je vais vous décrire.
En effet se passer de l'AHCI sur nos machines serait un peu bête.

Normalement vous avez du installer Intel Rapid Storage, le pilote du chipset et du controleur SATA.

Il s'avère que par défaut, un mode spécifique est activé est c'est justement ce mode qui pose problème.
C'est le LPM (Link Power Management)

Il faut le désactiver, et pour cela il faut aller faire un tour dans la base de registre.

Chercher HKLM/System/CurrentControlSet/services/iaStor/Parameters

La vous allez trouver Port0, Port1 etc
Et à l'interieur, vous trouverez ces clés

LPM
LPMDSTATE
LPMSTATE

changez la valeur de ces 3 clés à 0 dans tous les Ports

Enregistrez et redémarrer.

Normalement, plus de freeze.
  • 0

#2
BlackSad

BlackSad

    Le plus félin des administrateurs.

  • Administrateur
  • 21 481 messages
  • LocalisationGrenoble
Oui merci . Cette astuce est sur le site crucial .

D'ailleur la deuxième solution c'est de supprimer intel rapid storage et de mettre celui de windows . Résultat tu gagne des perf .
  • 0
<span style="font-size:12px;"><span style="color:rgb(255,0,0);"><strong>ALIENWARE 17 R3 : I76820HK oc LVL 3 à 4Ghz, 16GO DDR4 2133, GTX980M 8GO, 2x SSD m2 nvme 1TO (raid 0 = 2 To), HDD 1TO 7200Tr, Wifi/Bluetooth 8260AC, Ecran ULTRA HD, Sac à dos Vindicator, Garantie 4ans. Tapis Razer Goliathus avec une Orochi 2015.</strong></span></span>

#3
Kenshiroh

Kenshiroh

    Grand Geek

  • Membre
  • 717 messages
Merci pour l'info, je l'avais vu aussi quelque part... :)
C'est un super ssd ce m4
  • 0
Asus G53Jw - sx276v
Intel i5 480m - 4Go DDR3 - Nvidia GTX 460m
Crucial M4 128Go + 500Go 5400tpm

#4
yobouton

yobouton

    En attente de Visa

  • Membre
  • 99 messages
c'est à dire supprimer intel rapid storage et mettre celui de windows?
  • 0

#5
BlackSad

BlackSad

    Le plus félin des administrateurs.

  • Administrateur
  • 21 481 messages
  • LocalisationGrenoble
Ba en gros tu install pas le driver intel rapid storage, et tu laisse windows installer le driver automatiquement ^^ . Et plus de bug, et les perf sont encore un poil meilleur .
  • 0
<span style="font-size:12px;"><span style="color:rgb(255,0,0);"><strong>ALIENWARE 17 R3 : I76820HK oc LVL 3 à 4Ghz, 16GO DDR4 2133, GTX980M 8GO, 2x SSD m2 nvme 1TO (raid 0 = 2 To), HDD 1TO 7200Tr, Wifi/Bluetooth 8260AC, Ecran ULTRA HD, Sac à dos Vindicator, Garantie 4ans. Tapis Razer Goliathus avec une Orochi 2015.</strong></span></span>

#6
Guest_samjac_*

Guest_samjac_*
  • Visiteurs
Salut à tous,

Enfin je trouve un semblant de réponse à ces freezes permanent. Cela fait depuis un moment que je me trimballe sa avec mon PC flambant neuf (seven familial 64bit sur SSD OCZ vertex 3.0, CM ASUS P8P67PRO, 8giga corsair xms3...). Je viens de constater que effectivement, l'observateur enregistre bien une erreur "Le périphérique \Device\Ide\iaStor0 n'a pas répondu dans le délai imparti." et ceux juste au moment de la freeze. Apparement il y a pas mal de bug a se niveau vu le nombre de forum que j'ai visité et qui en parle. J'ai essayé d'aller modifier les paramètres du iaStor sous regedit mais je ne retrouve pas les clefs à modifier (il y en a pas mal à vrai dire et mes connaissances en info sont plutôt limités). Sur le port 1 et 2 on retrouve "iaStor", "IAStorDataMgrSvc et "iaStorV", apparement pas de différence entre les deux. Au lieu de faire une bêtise je préfère demander si par hasard vous avez plus d'info à ce niveau. Sinon j'ai aussi pensé à la deuxième solution mais la aussi je ne m'y connais pas asser pour entreprendre la désinstalation de Intel Rapid Storage. Y a pas moyen de le remplacer directement en l'écrasant avec ceux de windows?

Merci
  • 0

#7
yobouton

yobouton

    En attente de Visa

  • Membre
  • 99 messages
Je trouves pas intel rapid storage sur mon pc, à quel moment aurais-je du l'installer si ça avait été le cas ?

Par contre j'ai intel turbo boost, serait-ce ça ?
D'ailleurs ça sert à quoi ?
  • 0

#8
Wuinny

Wuinny

    En attente de Visa

  • Membre
  • 61 messages
j'ai eu le problème avec mon M4, je devenais dingue.

J'ai utilisé cette méthode pour régler le problème. Crucial a néanmoins sortis un firmware pour corriger le soucis.
  • 0
Asus G73SW-TY027V / SSD Crucial M4

#9
Ail-eYe-Aille !

Ail-eYe-Aille !

    Expert reconnu

  • Membre
  • 910 messages
  • Localisation?Divulgation Interdite..

Je trouves pas intel rapid storage sur mon pc, à quel moment aurais-je du l'installer si ça avait été le cas ?

Par contre j'ai intel turbo boost, serait-ce ça ?
D'ailleurs ça sert à quoi ?

Le Intel Rapid Storage Technology, IRST pour les intimes, est un contrôleur de stockage qui s'occupe de gérer la protion RAID d'une bécane. Si tu n'as pas deux disques (HDD ou SSD) en RAID ? Aucune utilité !

Par ailleurs, le Intel Turbo Boost est une fonction qu'Intel intègre à ses processeurs et qui permet un cadençage plus élevé sur plusieurs coeurs à la fois lorsque Windows le requiert; rien à voir avec les disques, qu'ils soient nommés SSD ou dénommés HDD...

;)
  • 0
[align=center]M17Xr2 920XM 8GB1333 2X160GB-X25M-RAID0-SSD HD4870XF 1920X1200 RGB LED[/align]

#10
yobouton

yobouton

    En attente de Visa

  • Membre
  • 99 messages
merci pour ces réponses toujours aussi précises
  • 0




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)