Aller au contenu

Change
Photo

Comment forcer mon ecran a fonctionner en à 50 hz ?


  • Veuillez vous connecter pour répondre
15 réponses à ce sujet

#1
rag83

rag83

    Touriste

  • Membre
  • 338 messages
J'aurais une petite question, j'ai remarqué que certains jeux auxquels je joue ne sont pas fluides, alors qu'ils tournent pourtant à 60 fps avec de rares chutes de framerate a 50-55, et cela provoque des micro saccades tres desagreables (dirt 2 par exemple).

J'ai lu pas mal de commentaires a droite et a gauche sur le sujet sans trouver de solution qui fonctionne.

Ma question est la suivante : comme apparemment ce n'est pas le nombre de fps mais la variation de ce framerate, aussi infime soit-elle, qui provoque ces micro saccades, s'il etait possible de bloquer le jeu a 50 fps max le probleme disparaitrait non ?

Donc je voudrais savoir s'il est possible de forcer un ecran a fonctionner à 50 hz, ensuite j'active la vsync dans le jeux et le tour est joué.

Est-ce possible et si oui comment, est ce que ca ne risque pas d'abimer nos ecrans de portable qui tournent habituellement a 60 hz ?

Merci de vos reponses.
  • 0

MSI GT80S : I7-6820HK / SLI 980M / 32 GO RAM 2133 Mhz / 2 x 256 GO Samsung 950 PRO + 1 TO 7200 RPM


#2
ziwa_68

ziwa_68

    Geek confirmé

  • Membre
  • 933 messages
  • LocalisationHaut-Rhin
On ne peut pas avoir en dessous de 60 Hz pour les écrans de PC, exception pour les sorties TV.

Le 60Hz vient des US, où tous leurs appareils sont basé sur le 60HZ : électricité, tv, ...

A l'époque les moniteurs et n'était pas aussi technologiquement avancé que les nôtres et se servait du secteur pour la synchronisation des images. Un dispositif analogique permettait de recevoir le signal video et de l'envoyer vers le tube au bon moment (ligne à retard).

Depuis l'électronique a évolué, les moniteurs sont devenus indépendant du secteur, mais l'informatique a garder le norme US, 60 Hz.

Pour bloquer le framerate des jeux, il doit y avoir des utilitaires pour ça.

Modifié par ziwa_68, 28 novembre 2010 - 15:09.

  • 0

#3
Xidus

Xidus

    Geek padawan

  • Membre
  • 3 271 messages
Tu peux peut-être regarder s'il n'y a pas un fichier config pour Dirt2. Si c'est le cas, tu dois surement pouvoir brider le nombre max de FPS.
  • 0
Macbook Pro 13" - OSx Lion - i5 2435M - 4 go DDR3 - DD 500 go

#4
rag83

rag83

    Touriste

  • Membre
  • 338 messages
Oui en effet ziwa, peut etre qu'utiliser un log pour ça serait le plus simple, je vais voir si ça existe.

Sinon spe il y a bien un fichier de config pour dirt2 mais j'ai pas vu de possibilité de brider le nombre de fps, a part de mettre 50 hz mais ça marche pas, dans le jeu ca se remet tout seul a 60 :box:
  • 0

MSI GT80S : I7-6820HK / SLI 980M / 32 GO RAM 2133 Mhz / 2 x 256 GO Samsung 950 PRO + 1 TO 7200 RPM


#5
Xidus

Xidus

    Geek padawan

  • Membre
  • 3 271 messages
Tu héberger le fichier cfg pour que je puisse regarder les options disponibles ?
  • 0
Macbook Pro 13" - OSx Lion - i5 2435M - 4 go DDR3 - DD 500 go

#6
rag83

rag83

    Touriste

  • Membre
  • 338 messages

Tu héberger le fichier cfg pour que je puisse regarder les options disponibles ?

copier-coller vite fait du cfg

<?xml version="1.0" encoding="UTF-8" ?>
<hardware_settings_config version="51">
<cpu>
<threadStrategy parallelUpdateRender="true" workerMapFile="system/workerMap8Core.xml" forceFeedbackProcessor="6" dvdStorageProcessor="7" dataSetMonitorProcessor="4" renderProcessor="0" updateProcessor="2" fileStreamProcessor="5" />
</cpu>
<audio_card>
<audio mixing="software" />
</audio_card>
<graphics_card>
<directx forcedx9="false" />
<resolution width="1920" height="1080" aspect="normal" fullscreen="true" vsync="1" multisampling="off">
<refreshRate rate="60" />
</resolution>
<gamma level="1.0" />
</graphics_card>
<graphics_detail level="high" />
<shadows enabled="false" size="512" maskQuality="1" />
<particles enabled="false" wind="false" dynamicRes="true" />
<crowd enabled="false" detail="1" tessellation="false" />
<cloth enabled="false" detail="1" />
<postprocess quality="0" />
<groundcover mode="off" clutter="false" />
<objects lod="0.5" maxlod="1" />
<trees lod="0.5" maxlod="1" />
<vehicles characterQuality="0" lodQuality="0" />
<envmap faces="0" size="256" forceBilinear="true" />
<water update="false" detail="0" tessellation="false" />
<mirrors enabled="false" forceBilinear="true" width="256" height="64" car_maxlod="4" car_culldist="0.0" />
<skidmarks enabled="false" />
<dynamic_ambient_occ enabled="true" quality="0" />
<night_lighting volumes="false" lights="150" shadows="false" />
<physics environmentalDamage="true" vehicleDamage="true" />
<input device_type="auto" />
<motion enabled="true" ip="dbox" port="20777" delay="1" extradata="0" />
</hardware_settings_config>

Sinon j'ai trouvé ça sur un autre forum, je copie-colle je sais pas si j'ai le droit si c'est pas le cas qu'un modo le supprime c'est pas grave

•Si tu n'actives pas la synchro' verticale, la carte graphique rendra autant d'image par seconde que cela lui est possible. Problème ton écran lui est soumis à un taux de rafraichissement fixe (ce n'est pas exactement vrai sur le LCD ou l'inertie des cristaux liquide joue plus sensiblement->rémanence) : des images risquent donc fort de n'avoir pu être affichées que partiellement avant qu'on passe à la seconde trame : les images apparaissent "déchirées", et de petites fluctuation du framerate donne une impression de µsaccades. Pour ma part je ne supporte pas. Ce pb est aussi vrai sur un CRT que sur un LCD...
•Avec la synchro' verticale,la carte graphique "attend" l'écran. Le gros pb c'est que cela implique que la fréquence d'affichage soit une fraction de la fréquence d'affichage : 1/1, 1/2, 1/3... Là où ça devient TRES génant c que si la carte n'est capable d'afficher que 57fps (par exemple), alors que ton écran est à 60Hz, elle ne pourra pas l'alimenter à raison de 60fps prévues,et passera donc brusquement à 30fps. D'où tes variation brutales de framerate ! La solution consiste à jouer sur le fréquence de rafraichissement (120Hz sur un CRT par exemple laisse possible : 120FPS, 60fps, 40fps, 30fps, 24fps, 20fps...), ou a activer le tripple buffer (il bouffe de la ram sur la carte graphique en mettant uen tramme supplémentaire en attente, mais évite les variations trop fréquentes).

Comment faire pour forcer le tripple buffering dans les jeux D3D, j'ai l'impression que c'est pas possible, j'ai essayé ati tray tools ---> BSOD, et D3D overrider il me fait planter dirt2, car le probleme c'est que les derniers versions datent de + d'1 an donc c'est pas top avec les derniers drivers :nana:
  • 0

MSI GT80S : I7-6820HK / SLI 980M / 32 GO RAM 2133 Mhz / 2 x 256 GO Samsung 950 PRO + 1 TO 7200 RPM


#7
Xidus

Xidus

    Geek padawan

  • Membre
  • 3 271 messages
Pour le Triple buffering, aucune idée.

Pour le fichier cfg, aucune option n'est présente pour brider le nombre de FPS, à voir sur le net si on peut ajouter une ligne pour le faire.
  • 0
Macbook Pro 13" - OSx Lion - i5 2435M - 4 go DDR3 - DD 500 go

#8
rag83

rag83

    Touriste

  • Membre
  • 338 messages
En tous cas je viens de tester sur l'ecran de mon salon via la sortie HDMI ou la je peux forcer le 50 hz, resultat une fluidité absolue du début à la fin. Je veux faire pareil sur le portable rha :gne:
  • 0

MSI GT80S : I7-6820HK / SLI 980M / 32 GO RAM 2133 Mhz / 2 x 256 GO Samsung 950 PRO + 1 TO 7200 RPM


#9
akluin

akluin

    Pur esprit Geek

  • Membre
  • 8 004 messages
  • LocalisationA la croisée des chemins
dans le CCC Onglet graphique ---> 3D puis onglet tout tu descend tout en bas et tu coche triple buffering.
  • 0
retour à l alienware m17x r2 full alu

#10
Arkh

Arkh

    Geek diplomé

  • Membre
  • 2 259 messages
Paramètres de jeux ou paramètres ATI (NVIDIA permet de le faire en forcé pour toutes les applis (GL/D3D), pourquoi pas ATI?)...

par contre pour le CFG, à moins d'être aveugle, il faut changer :

<refreshRate rate="60" />

Tu as aussi à mettre à 0 pour le VSYNC :

<resolution width="1920" height="1080" aspect="normal" fullscreen="true" vsync="1" multisampling="off">


  • 0

D900F : I7 950 (8x3.1Ghz) /// 6GB DDR3 1333MHz (3x2Go) /// GTX 280M (128CC/1GHz/1Go) /// 2x320GB 7200Trs/min /// WUXGA Non-Glare Screen 1920x1200 /// Razer Abyssus /// NC-2000 /// By PcSystems-EvolutionX /// Powered by Debian!

> Get Process Explorer


#11
Xidus

Xidus

    Geek padawan

  • Membre
  • 3 271 messages
Pour le refresh rate, c'est n'est pas ça, puisqu'il dit qu'en change le taux de rafraichissement à 50, ça ne fonctionne pas. :/
Pour le VSYNC, s'il le désactive, il sera encore moins bridé, même pas du tout, alors qu'il veut limiter à 50.
  • 0
Macbook Pro 13" - OSx Lion - i5 2435M - 4 go DDR3 - DD 500 go

#12
rag83

rag83

    Touriste

  • Membre
  • 338 messages

Pour le refresh rate, c'est n'est pas ça, puisqu'il dit qu'en change le taux de rafraichissement à 50, ça ne fonctionne pas. :/
Pour le VSYNC, s'il le désactive, il sera encore moins bridé, même pas du tout, alors qu'il veut limiter à 50.

Tout a fait, je te rassure arkh je suis pas aveugle et ce que tu dis c'est le premier truc que j'ai testé et ça marche pas. Vsync 0 non car plus de limites...

dans le CCC Onglet graphique ---> 3D puis onglet tout tu descend tout en bas et tu coche triple buffering.

akluin c'est pas un peu bourrin comme methode ça ? De plus le triple buffering dans le CCC c'est que pour l'open GL :eyes:
  • 0

MSI GT80S : I7-6820HK / SLI 980M / 32 GO RAM 2133 Mhz / 2 x 256 GO Samsung 950 PRO + 1 TO 7200 RPM


#13
Arkh

Arkh

    Geek diplomé

  • Membre
  • 2 259 messages
essaies refreshrate=40 ou 30 (c'est le nombre d'images produite par le moteur, s'il passe en dessous d'un certain trigger, ça stabilisera probablement...)
  • 0

D900F : I7 950 (8x3.1Ghz) /// 6GB DDR3 1333MHz (3x2Go) /// GTX 280M (128CC/1GHz/1Go) /// 2x320GB 7200Trs/min /// WUXGA Non-Glare Screen 1920x1200 /// Razer Abyssus /// NC-2000 /// By PcSystems-EvolutionX /// Powered by Debian!

> Get Process Explorer


#14
rag83

rag83

    Touriste

  • Membre
  • 338 messages

essaies refreshrate=40 ou 30 (c'est le nombre d'images produite par le moteur, s'il passe en dessous d'un certain trigger, ça stabilisera probablement...)

non ça marche pas mais ça marchait deja pas avec 50 alors :chant:

Modifié par rag83, 28 novembre 2010 - 21:10.

  • 0

MSI GT80S : I7-6820HK / SLI 980M / 32 GO RAM 2133 Mhz / 2 x 256 GO Samsung 950 PRO + 1 TO 7200 RPM


#15
Arkh

Arkh

    Geek diplomé

  • Membre
  • 2 259 messages
Tu as essayé à 5?
Tu vois une différence?
  • 0

D900F : I7 950 (8x3.1Ghz) /// 6GB DDR3 1333MHz (3x2Go) /// GTX 280M (128CC/1GHz/1Go) /// 2x320GB 7200Trs/min /// WUXGA Non-Glare Screen 1920x1200 /// Razer Abyssus /// NC-2000 /// By PcSystems-EvolutionX /// Powered by Debian!

> Get Process Explorer


#16
Mauoi

Mauoi

    Petit Geek

  • Membre
  • 555 messages
pour les micro saccades met la qualité du publique sur élevée ou moyen cela désactive la tesselation qui (a mes yeux) ne change absolument rien si ce n'est créer des lags par moments ainsi qu'une perte de 10/15 fps...
t'a aussi les reflet tu les met en élevée au lieu de ultra et ca passe nickel (sans changer vraiment grand chose graphiquement)après tu mat refresh rate a 60 et la vsync....(perso moi je désactive la vsync car c'est elle qui me crée les micro saccades...mais j'ai un ecran 120Hz donc pas trop comparable)

Sinon t'a bien les derniers drivers ? (question bête mais bon...on sait jamais...)
  • 0
portable:AMILO XI 1554 t7200+mobility X1900Mobility radeon HD4670+4Go RAM+DD Seagate momentus 7200.4+Windows 7 intégrale 64bits
ASUS G53SX-SX024V: i7 2630qm + 560m
Bureau:i5 750+5850oc+6Go ddr3




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)