Aller au contenu

Change
Photo

Kali: Réinstaller Grub Dans La Mbr.


  • Veuillez vous connecter pour répondre
5 réponses à ce sujet

#1
TiTanS

TiTanS

    En attente de Visa

  • Membre
  • 15 messages
  • LocalisationTroyes

bonjour,

Possédant sur mon disque dur d'une partition windows crypter par trucrypte "/dev/sda1" et une partition étendu kali non crypter  "/dev/sda2" contenant "/dev/sda5" ext4 et "/dev/sda6/" linux swap.
j'ai suivi ce tuto: http://www.artiflo.n...-windows-linux/
mais je suis bloqué à la partie 8.

lorsque je tape la commande indiqué dans la partie 8 ça me dit "unknown command 'install'." Comment puis-je faire ?

Ma version GRUB est 1.99-27+deb7u2.

Je vous remercie par avance pour votre aide.


  • 0

Fractal xl: asus maximus extreme V - i7 2700k @ 3.5 - 8 gb DDr3 2133 MHz - Zotac GTX 660Ti 2 gb - SSD Serie830 256 Gb - 2 WD green 6 Gb/s: 1To, 2To 7200 Tr/min - Asus Xonar essence STX - Corsair cwc-h80.

liyama full HD 24" + optoma full HD 92"

Raccat isku+Kone

Asus G73s: i7 2630Qm @ 2.0 - 17,3" - 8 gb DDr3 1600 MHz - GTX 460M 1.5 gb - 1 WD 500 gb 7200 tr/min + 1 momentus XT 500 gb 7200 tr/min. Mort :angry: :arf:

Clevo P150Em: i7 2630Qm @ 2.0 - 15,6" - 8 gb DDr3 1600 MHz - GTX 675MX - 1 momentus xt 500 gb 7200 tr/min.


#2
Leeloyd

Leeloyd

    Geek confirmé

  • Membre
  • 1 047 messages

T'as lancé grub en root ?

# grub

Puis dans l'invite de commande de grub t'as tapé install ... ?

grub > install(hd0,*)...

  • 0

Alienware 15R3 : I7-6820HK @3.6GHz - GTX 1070 - RAM 16Go - SANDISK ULTRA II 960Go
GX60 Hitman Edition : A10-5750m ES @4.0GHz - HD8970m - RAM 8Go - SSD V300 120Go - HDD 750Go
M570RU-U  : X7900 ES @3.2.Hz - GTX 8800m - RAM 4Go - HDD WD Scorpio Black 320Go
T4G  : Zalman Z9+ -  I5 2500K @4.7GHz - GALAX GTX 980 SOC -  RAM Corsair Dominator 8Go 
 
[OSVR] HDK 1.3


#3
TiTanS

TiTanS

    En attente de Visa

  • Membre
  • 15 messages
  • LocalisationTroyes

Pour mettre grub en root je doit utilisé la commande  # grub ?

Car j'ai tapé install est à chaque fois ça me dit "unknown command".


  • 0

Fractal xl: asus maximus extreme V - i7 2700k @ 3.5 - 8 gb DDr3 2133 MHz - Zotac GTX 660Ti 2 gb - SSD Serie830 256 Gb - 2 WD green 6 Gb/s: 1To, 2To 7200 Tr/min - Asus Xonar essence STX - Corsair cwc-h80.

liyama full HD 24" + optoma full HD 92"

Raccat isku+Kone

Asus G73s: i7 2630Qm @ 2.0 - 17,3" - 8 gb DDr3 1600 MHz - GTX 460M 1.5 gb - 1 WD 500 gb 7200 tr/min + 1 momentus XT 500 gb 7200 tr/min. Mort :angry: :arf:

Clevo P150Em: i7 2630Qm @ 2.0 - 15,6" - 8 gb DDr3 1600 MHz - GTX 675MX - 1 momentus xt 500 gb 7200 tr/min.


#4
thehunt33r

thehunt33r

    Grammar Watcher

  • Moderateur
  • 9 167 messages
  • LocalisationRennes

Tu dois juste utiliser la commande

root@hostname # grub

Ensuite, tu pourras normalement utiliser la commande install. Si tu ne peux pas, y a un problème...


  • 0

T4G : Vendu :( (en arrivage : 5820K,32gb DDR4, 970)
P4G : PWNPCS P150SM : 4700MQ, GTX780m, 16gb DDR3, 1*mSATA M500 240GB et 2* Sandisk Ultra Plus 128GB, Ecran mat sous W8.1 Pro X64 & Fedora 21
Tablet4G : Dell Venue 8 Pro : Atom Z3740, 2gb DDR3, Windows 8.1

Server4G : HP N54L Debian
Mechs : IBM Model M 1994 - KBT Poker II Cherry MX Black - CM Storm Novatouch (Topre 45gr)

Spoiler

Spoiler

#5
TiTanS

TiTanS

    En attente de Visa

  • Membre
  • 15 messages
  • LocalisationTroyes

J'execute la commande grub > install(hd0, dans le terminal grub ou le terminal de kali ?


Modifié par TiTanS, 28 juin 2015 - 12:01.

  • 0

Fractal xl: asus maximus extreme V - i7 2700k @ 3.5 - 8 gb DDr3 2133 MHz - Zotac GTX 660Ti 2 gb - SSD Serie830 256 Gb - 2 WD green 6 Gb/s: 1To, 2To 7200 Tr/min - Asus Xonar essence STX - Corsair cwc-h80.

liyama full HD 24" + optoma full HD 92"

Raccat isku+Kone

Asus G73s: i7 2630Qm @ 2.0 - 17,3" - 8 gb DDr3 1600 MHz - GTX 460M 1.5 gb - 1 WD 500 gb 7200 tr/min + 1 momentus XT 500 gb 7200 tr/min. Mort :angry: :arf:

Clevo P150Em: i7 2630Qm @ 2.0 - 15,6" - 8 gb DDr3 1600 MHz - GTX 675MX - 1 momentus xt 500 gb 7200 tr/min.


#6
thehunt33r

thehunt33r

    Grammar Watcher

  • Moderateur
  • 9 167 messages
  • LocalisationRennes

Dans le terminal grub...

et la commande est : install(hd0,x) 


  • 0

T4G : Vendu :( (en arrivage : 5820K,32gb DDR4, 970)
P4G : PWNPCS P150SM : 4700MQ, GTX780m, 16gb DDR3, 1*mSATA M500 240GB et 2* Sandisk Ultra Plus 128GB, Ecran mat sous W8.1 Pro X64 & Fedora 21
Tablet4G : Dell Venue 8 Pro : Atom Z3740, 2gb DDR3, Windows 8.1

Server4G : HP N54L Debian
Mechs : IBM Model M 1994 - KBT Poker II Cherry MX Black - CM Storm Novatouch (Topre 45gr)

Spoiler

Spoiler




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)