Aller au contenu

Change
Photo

Gestion Du Clavier Rétroéclairé Sous Gnu/linux


  • Veuillez vous connecter pour répondre
11 réponses à ce sujet

#1
Mister Tux

Mister Tux

    Touriste

  • Membre
  • 233 messages

Bonsoir,

 

il existe sous Gnu/linux, un script qui permet de gérer le clavier rétroéclairé présent sur les modèles PxxxEm, et supérieurs. Son nom : clevo-wmi.

 

Vous trouverez les sources au niveau de cette adresse : http://sourceforge.n...ster/tree/docs/

 

Explication ici : http://askubuntu.com...n-clevo-laptops (en anglais).

 

Une interface graphique existe : clevokbledui. Plus d'infos ici : https://github.com/i...ne/clevokbledui

 

P.S: Pour info, les éléments sont présents dans le git. Pour les récupérer, lire l'explication ci-dessus (cfr. lien). Une compilation sera peut être nécessaire. Concernant, l'interface graphique, un paquet .deb doit être présent dans le git (cfr. 3ème lien).

 

 


  • 1

#2
Arkh

Arkh

    Geek diplomé

  • Membre
  • 2 259 messages

Cool, merci pour le lien... reste plus qu'à tweaker en fonction des paramètres du système (changement de couleur à la réception d'un mail, batterie chargée/déchargée, etc.)


  • 0

D900F : I7 950 (8x3.1Ghz) /// 6GB DDR3 1333MHz (3x2Go) /// GTX 280M (128CC/1GHz/1Go) /// 2x320GB 7200Trs/min /// WUXGA Non-Glare Screen 1920x1200 /// Razer Abyssus /// NC-2000 /// By PcSystems-EvolutionX /// Powered by Debian!

> Get Process Explorer


#3
Mister Tux

Mister Tux

    Touriste

  • Membre
  • 233 messages

Bonsoir,

 

je n'ai pas remarqué de fichier .tar.gz, donc il faut récupérer le contenu du git avec la commande adéquate dans le lien de l'explication. Les utilisateurs de la distribution ArchLinux ont plus de chance, car les devs de celle-ci ont compilés les paquets.


  • 0

#4
Arkh

Arkh

    Geek diplomé

  • Membre
  • 2 259 messages

C'est pas inhumain :

# Pour Debian/Ubuntu/Mint et derives

cd $HOME

# Si vous n'avez pas Git : 
sudo apt-get install git

# Recuperer le code : 
git clone git://git.code.sf.net/p/clevo-wmi/code clevo-wmi-code

# Recuperer les sources du noyau : 
sudo apt-get install linux-headers-$(uname -r)

# Allez dans le repo et compiler :
cd clevo-wmi-code
make

# Inserez le module dans le noyau : 
sudo modprobe clevo_wmi

# Tester si le module est bien en place : 
lsmod | grep clevo_wmi

# Installer au démarrage (SI TOUT FONCTIONNE) : editer /etc/modules et ajouter la ligne : 
clevo_wmi

#cf le Readme dans le repo pour la suite...


  • 0

D900F : I7 950 (8x3.1Ghz) /// 6GB DDR3 1333MHz (3x2Go) /// GTX 280M (128CC/1GHz/1Go) /// 2x320GB 7200Trs/min /// WUXGA Non-Glare Screen 1920x1200 /// Razer Abyssus /// NC-2000 /// By PcSystems-EvolutionX /// Powered by Debian!

> Get Process Explorer


#5
Mister Tux

Mister Tux

    Touriste

  • Membre
  • 233 messages

Bonsoir,

 

avez vous testé ?


  • 0

#6
Mister Tux

Mister Tux

    Touriste

  • Membre
  • 233 messages

Bonjour,

 

je me permets de vous fournir un autre lien. Dans ce cas-ci, le module clevo-wmi a été compilé, et il porte le nom de tuxedo-wmi.

lien: http://www.linux-onl...ead&threadID=26

L'inconvénient, c'est que l'explication d'utilisation est en allemand. :(


  • 0

#7
Mister Tux

Mister Tux

    Touriste

  • Membre
  • 233 messages

Bonsoir,

 

je tenais à signaler que j'ai testé tuxedo-wmi sur mon portable P170SM, et ça fonctionne parfaitement. :)

J'ai récupéré les sources, et j'ai compilé le module.

Tuxedo-wmi indique qu'il gère le mode avion du Clevo, mais lorsque j'appuye sur la FN+celle correspondante à l'avion, rien ne se passe (le témoin ne s'allume pas). Tuxedo-wmi prend t-il en charge ce mode ? Je sais pas. Par contre, le clavier rétro-éclairé, oui. :)


  • 0

#8
thehunt33r

thehunt33r

    Grammar Watcher

  • Moderateur
  • 9 167 messages
  • LocalisationRennes

Bonjour,

 

J'écris dans ce sujet car j'ai un problème avec Tuxedo, sous Fedora 20.

En effet, j'ai bien le rétroéclairage du clavier, et le mode avion qui s'active (sous Fedora uniquement, pas de voyant). Cependant, je n'ai pas de fichier Tuxedo dans /etc/modprobe.d

Savez vous si c'est normal ? Bug connu ? J'ai rien trouvé à propos de ça.


  • 0

T4G : Vendu :( (en arrivage : 5820K,32gb DDR4, 970)
P4G : PWNPCS P150SM : 4700MQ, GTX780m, 16gb DDR3, 1*mSATA M500 240GB et 2* Sandisk Ultra Plus 128GB, Ecran mat sous W8.1 Pro X64 & Fedora 21
Tablet4G : Dell Venue 8 Pro : Atom Z3740, 2gb DDR3, Windows 8.1

Server4G : HP N54L Debian
Mechs : IBM Model M 1994 - KBT Poker II Cherry MX Black - CM Storm Novatouch (Topre 45gr)

Spoiler

Spoiler

#9
Arkh

Arkh

    Geek diplomé

  • Membre
  • 2 259 messages

Regarde s'il n'est pas ailleurs avant avec locate ou find :

locate Tuxedo
# ou encore
find / -name Tuxedo

  • 0

D900F : I7 950 (8x3.1Ghz) /// 6GB DDR3 1333MHz (3x2Go) /// GTX 280M (128CC/1GHz/1Go) /// 2x320GB 7200Trs/min /// WUXGA Non-Glare Screen 1920x1200 /// Razer Abyssus /// NC-2000 /// By PcSystems-EvolutionX /// Powered by Debian!

> Get Process Explorer


#10
Mister Tux

Mister Tux

    Touriste

  • Membre
  • 233 messages

Bonsoir,

 

Bonjour,

 

J'écris dans ce sujet car j'ai un problème avec Tuxedo, sous Fedora 20.

En effet, j'ai bien le rétroéclairage du clavier, et le mode avion qui s'active (sous Fedora uniquement, pas de voyant). Cependant, je n'ai pas de fichier Tuxedo dans /etc/modprobe.d

Savez vous si c'est normal ? Bug connu ? J'ai rien trouvé à propos de ça.

 

oui, il faut créer le fichier tuxedo-wmi.conf dans /etc/modprobe.d

Dans ce fichier, tu peux indiquer les informations suivantes : options tuxedo-wmi kb_color=white kb_brightness=5

kb_color, c'est la couleur que tu désires : rouge (red), bleu (blue), etc. Et si tu veux plusieurs couleurs (3 couleurs maximum), tu peux définir comme ceci : "kb_color=red,blue,white" (vérifier s'il faut les guillemets). Les couleurs disponibles sont bleu, rouge, vert, cyan, magenta, jaune, et blanc. Si tu veux qu'une partie du clavier soit allumée (ex: clavier numérique uniquement en rouge), tu définira kb_color comme ceci : "kb_color=,,red", ou comme ceci : "kb_color=black,black,red". kb_brightness est le niveau de luminosité (de 0 à 10). Si tu indiques 0, le clavier est éteint, mais il est préférable de définir une autre valeur (ex: 1) au minimum.

Pour info, dkms doit être installé, et si le fichier source est compilé, le fichier obtenu (tuxedo-wmi.ko) doit être placé dans /lib/modules/n°du noyau/kernel/drivers/platform/x86/

Ensuite, vous pouvez exécuter la commande : depmod -a (en root), et vous indiquez dans /etc/modules, l'entrée suivante : tuxedo-wmi

 

Sinon pour le mode avion, lorsque j'appuye sur la touche FN+F10 (mode avion), le témoin ne s'active pas. Donc, je sais pas si cela fonctionne ou pas.


Modifié par Mister Tux, 18 février 2014 - 00:19.

  • 0

#11
thehunt33r

thehunt33r

    Grammar Watcher

  • Moderateur
  • 9 167 messages
  • LocalisationRennes

Bonsoir,

 

Effectivement je m'en suis rendu compte, et après avoir créé le fichier, ça marche.

 

Quand au mode avion, même si le témoin ne s'allume pas, le Wifi est coupé sur mon P150SM.


  • 0

T4G : Vendu :( (en arrivage : 5820K,32gb DDR4, 970)
P4G : PWNPCS P150SM : 4700MQ, GTX780m, 16gb DDR3, 1*mSATA M500 240GB et 2* Sandisk Ultra Plus 128GB, Ecran mat sous W8.1 Pro X64 & Fedora 21
Tablet4G : Dell Venue 8 Pro : Atom Z3740, 2gb DDR3, Windows 8.1

Server4G : HP N54L Debian
Mechs : IBM Model M 1994 - KBT Poker II Cherry MX Black - CM Storm Novatouch (Topre 45gr)

Spoiler

Spoiler

#12
Mister Tux

Mister Tux

    Touriste

  • Membre
  • 233 messages

Une interface graphique existe, son nom : Clevokbledui. Mais je ne sais pas si elle fonctionne avec tuxedo-wmi.

 

Le logiciel peut etre récupéré ici : https://github.com/i...ne/clevokbledui


  • 0




0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)