Aller au contenu

Change
Photo

Son Jeu Sur Enceinte/son Ts Sur Casque


  • Veuillez vous connecter pour répondre
11 réponses à ce sujet

#1
Arty

Arty

    En attente de Visa

  • Membre
  • 75 messages

Bonjour, bonsoir

 

J'ai récemment acheté un Msi GT70 0nd-1212xfr et j'aimerais savoir s'il est possible sur ce PC de séparé les flux audio.

En gros comme le titre du topic l'indique, j'aimerais que les sons du PC (jeux, musiques, internet ect ...) sortent par les enceintes du PC (ou de ma chaine hifi/enceintes quand je les branches) et que le son de teamspeak/skype ou ce genre de logiciel arrive dans mon casque.

 

J'avais réussi à faire ça sur mon précédent PC (un asus x71sl) de façon autonome. Il séparait automatiquement mon son teamspeak du pc quand je branchais mon casque.

 

Merci d'avance =).


  • 0

#2
Kiss4u

Kiss4u

    Newbie

  • Membre
  • 438 messages

Bonsoir,

 

En fait ce réglage dépend directement de Windows et des applications (TS et Jeux dans votre cas).

 

  • Dans un premier temps, branchez tous les périphériques audio que vous souhaitez attribuer.
  • Rendez-vous dans ensuite dans le Panneau de configuration / Materiel et Audio / Son.
  • Sous l'onglet Lecture, faites un clic-droit sur le périphérique des enceintes et choisissez Définir en tant que périphérique par défaut.
  • Faites ensuite un clic-droit sur le périphérique des écouteurs et choisissez Définir en tant que périphérique de communication par défaut.
  • Sous l'onglet Enregistrement, faites un clic-droit sur le périphérique des écouteurs et choisissez Définir en tant que périphérique par défaut.

Ensuite :

  • Lancez votre application vocale TS puis dans le réglages de sortie choisissez le périphérique des écouteurs et dans le réglage d'entrée choisissez les écouteurs (si votre casque possède un micro) comme périphérique d'enregistrement.
  • Lancez le jeu et dans les réglages du son choisissez comme sortie le Périphérique par défaut.

  • 0

WallPapers MSI Dragon Army inédits en exclusivité pour les visiteurs de P4G


717637buttonmsiwpFluidity.png423688msidragonarmytranslucentbutt.png749475msidragonarmylegendbutt.png152864buttonmsiwpTwinDragonRedSkin.png764418msidragonarmysinusoidalcolorsbutt.


#3
Arty

Arty

    En attente de Visa

  • Membre
  • 75 messages

Ça ne fonctionne malheureusement toujours pas.

 

J'ai pourtant suivis scrupuleusement ce que vous m'indiqué, j'ai par contre pris soins de cocher dans le gestionnaire realtek "faire lire deux flux audio différents et simultanés aux aux périphériques de sortie interne et externe" ainsi que "Séparé tous les jack d'entrée comme des périphériques d'entrés indépendants".

 

En faisant ça j'ai bien un casque qui s'affiche dans les périphériques de lecture en plus du haut parleurs, j'ai donc mis le périphérique des écouteurs en tant que périphérique de communication par défaut. Et ensuite sous TS je prend soin d'aller dans setting>options>playback et dans playback device je choisis "realtek HD audio 2nd output".

 

Du coup j'ai bien le son général qui sort de mon PC ou de ma chaine hifi quand je la branche mais par contre je n'entend aucun son qui pourrait provenir de mon casque (TS ou autre), même en cliquant droit puis "tester" dans le périphérique de lecture (sur le périphérique du casque), je n'entend aucun son.

 

Apres je peux me tromper sur l'emplacement des branchements, j'ai un peu tout essayé à priori sans succès. Je branche mon jack chaine hifi sur la première sortie audio (la plus proche de la sortie usb)  et mon casque sur la dernière (la plus éloigné de la sortie usb).

113007-msi-gt70.png


  • 0

#4
Kiss4u

Kiss4u

    Newbie

  • Membre
  • 438 messages

Vous devriez faire l'inverse : utiliser la sortie casque pour le casque et une des sorties ligne pour la chaine hifi.


  • 0

WallPapers MSI Dragon Army inédits en exclusivité pour les visiteurs de P4G


717637buttonmsiwpFluidity.png423688msidragonarmytranslucentbutt.png749475msidragonarmylegendbutt.png152864buttonmsiwpTwinDragonRedSkin.png764418msidragonarmysinusoidalcolorsbutt.


#5
Arty

Arty

    En attente de Visa

  • Membre
  • 75 messages

Même en inversant ça ne fonctionne pas, d'ailleurs que je branche ou non la chaine hifi ne change rien, je devrais pouvoir entendre les sons par les hauts parleurs du PC et TS par le casque.

Peut être des pilotes/drivers pas à jours ? Je suis sous seven 64 bit. Dans le gestionnaire de périph il me dit pourtant que tout est à jours.


  • 0

#6
Kiss4u

Kiss4u

    Newbie

  • Membre
  • 438 messages

Non ce n'est pas un problème de driver ou de matériel, c'est un problème d'attribution des entrées/sorties dans les différentes applications et dans Windows. Les gestionnaires sont parfois capricieux !

 

Vous auriez des captures d'écran ?


  • 0

WallPapers MSI Dragon Army inédits en exclusivité pour les visiteurs de P4G


717637buttonmsiwpFluidity.png423688msidragonarmytranslucentbutt.png749475msidragonarmylegendbutt.png152864buttonmsiwpTwinDragonRedSkin.png764418msidragonarmysinusoidalcolorsbutt.


#7
Arty

Arty

    En attente de Visa

  • Membre
  • 75 messages

Oui bien sur.

 

En gros après avoir branché mon casque dans la première sortie audio je configure tout ça.

 

En faisant ça, le son sort totalement par le casque sauf le son TS (qui devrait sortir sur "realtek HD audio nd output")

 

Si j'essaye de mettre le casque sur une des autres sorties audio (sauf sortie micro) le son du PC sort par les hauts parleurs mais je n'ai toujours rien dans le casque venant de TS (qui ne produit d'ailleurs aucun son même sur les hauts parleurs, sauf si je sélectionne les hauts parleurs dans "playback device") 


  • 0

#8
Arty

Arty

    En attente de Visa

  • Membre
  • 75 messages

Petit up.

 

Avec l'aide de ce post et de ce site (http://www.enceinte-...2-1,fr,8,77.cfm), j'ai donc connecté mes enceintes sur la sortie "line out" et mon casque sur  'sortie analogique stéréo pour écouteurs et casque audio".

 

Voici les correspondances des entrées/sorties de la carte son et leurs attributions sur le MSI GT70 (ces données sont celles de la norme PC99 et sont universelles) :

  • Symbole du Casque / vert pâle :
    • Sortie analogique stéréo pour écouteurs et casque audio.
    • Sortie audio numérique optique (S/PDIF).
    • Système surround = sortie pour HP avant.
  • Symbole du Micro / In = rose, Out = orange :
    • Entrée analogique pour micro
    • Système surround = sortie pour HP centre et Sub-woofer.
  • Symbole Line In (rond avec une flèche vers l’intérieur)​ / In = bleu clair, Out = noir :
    • Entrée audio analogique Line In.
    • Système surround = sortie pour HP arrière.
  • Symbole Line Out (rond avec une flèche vers l’extérieur) / Marron :
    • Sortie audio analogique Line Out (stéréo G/D).
    • Système surround = sortie pour HP d'effet panoramique gauche/droite (7.1).

 


 

Apres quand je configure realtek de cette maniere 

Je me retrouve avec le même son provenant des enceintes et du casque.

 

 

 

Et quand je tente de faire en sorte de séparer les flux audio, de cette manière

Je me retrouve avec le son provenant uniquement du casque, les enceintes elles ne délivrent plus aucun son.


  • 0

#9
Kiss4u

Kiss4u

    Newbie

  • Membre
  • 438 messages

Bonjour, 

 

Vos flux audio ne sont pas séparés. C'est pour cette raison que vous ne pouvez pas dissocier les sons en sortie.

 

Il faut attribuer le son Windows à l'un des périphériques et le son de l'application à l'autre.

 

D'autre part, si vous n'utilisez que le micro en tant que source d'entrée vers votre PC, vous n'avez pas besoin de séparer les périphériques d'enregistrements sur la carte RealTek.


  • 0

WallPapers MSI Dragon Army inédits en exclusivité pour les visiteurs de P4G


717637buttonmsiwpFluidity.png423688msidragonarmytranslucentbutt.png749475msidragonarmylegendbutt.png152864buttonmsiwpTwinDragonRedSkin.png764418msidragonarmysinusoidalcolorsbutt.


#10
Arty

Arty

    En attente de Visa

  • Membre
  • 75 messages

Bon ben après moulte recherches et différentes config je n'ai toujours pas réussi :(.

J'abandonne. 

Merci quand même.


  • 0

#11
Arty

Arty

    En attente de Visa

  • Membre
  • 75 messages

Double post, pas d’édit pour que ça soit visible.

J'ai donc finalement réussi à parvenir à mes fins ! C'était bien lié à un soucis de pilotes de périphérique ou de conflit logiciel. J'ai désinstaller realtek ainsi que tous les périphériques audio.

Au redémarrage, windows à simplement installer les périph solo (sans realtek donc) et je peux par l’intermédiaire du périphérique de lecture gérer mes sorties audio.

Le soucis viendrait donc de Realtek qui créerait un conflit. Sur certains forum, des gens disent que les versions trop récente de realtek engendre des problèmes. Je vais donc essayer de trouver une version antérieur de Realtek et voir si j'ai toujours ce problème.


Modifié par Arty, 12 septembre 2013 - 13:02.

  • 0

#12
Kiss4u

Kiss4u

    Newbie

  • Membre
  • 438 messages

Hello,

 

Pour info j'utilise la version 6.0.1.6873 du Gestionnaire audio HD Realtek et je peux gérer et attribuer correctement mes périphériques, sous Windows et avec le gestionnaire Realtek.


  • 0

WallPapers MSI Dragon Army inédits en exclusivité pour les visiteurs de P4G


717637buttonmsiwpFluidity.png423688msidragonarmytranslucentbutt.png749475msidragonarmylegendbutt.png152864buttonmsiwpTwinDragonRedSkin.png764418msidragonarmysinusoidalcolorsbutt.





0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)