Aller au contenu

Change
Photo

[Steam] Dysfonctionnement de GTA IV


  • Veuillez vous connecter pour répondre
11 réponses à ce sujet

#1
Slabre

Slabre

    Touriste

  • Membre
  • 254 messages

Salut :)

Comme j'ai eu mon nouveau PC j'ai du réinstaller Steam et télécharger tous les jeux sur mon PC.

 

Cependant, j'ai un petit soucis avec GTA IV : A chaque fois que je le lance, il me réinstalle le "Microsoft VIsual C++ 2005 Redistribuable". Enfin, déjà je ne comprends pas pourquoi mais c'est assez agaçant.

 

Ensuite, le jeu se lance : dans le menu principal avant de lancer le jeu en lui-même, je vais dans les options graphiques pour changer un peu tout (normal au premier lancement). Le soucis c'est que je ne peux rien changer, je peux sélectionner les différentes options, mais quand je souhaite changer, c'est comme si ça ne faisait rien. En prime, il m'est impossible de quitter ces options. J'ai beau faire Echap et valider par Entrée, je suis toujours dans les options.

 

J'ai ensuite essayé de jouer directement sans passer par les options, j'ai eu le droit à ça :

 

 

J'ai bien sûr aussi essayé de Vérifier l'intégralité du cache de mon jeu sur Steam, tous les fichiers ont été validés. Serait-ce à cause de Windows 8 ?

 

Des solutions ? :(


  • 0

[P4G actuel] : MSI GT60 0NC-446FR : Core i7 3630QM GTX 670MX 8Go RAM SSD 120Go + HDD 750Go Killer WiFi

[Ex-P4G] : ASUS G53SW-SZ143V : Core i7-2630QM GTX 460M 8Go RAM 2 x 500Go Momentus XT (SSH) Blu-Ray

Razer Imperator 2012 - Razer Goliathus Speed - Logitech G35 7.1 - Razer Onza Tournament


#2
jalaxx

jalaxx

    Force spéciale des Geek

  • Membre
  • 10 040 messages
  • LocalisationDiego

T'as essayé de lancer le jeu en "mode de compatibilité" pour xp sp3 ?


  • 0

 

MSI GT603Dmark11: P6463 /  Fire strike: P4257

 

76561198093015032.png

 


#3
Slabre

Slabre

    Touriste

  • Membre
  • 254 messages

Bah c'est sur Steam, c'est ça le problème, et j'ai pas envie de m'amuser à lancer le jeu depuis l'explorateur windows à chaque fois :/


  • 0

[P4G actuel] : MSI GT60 0NC-446FR : Core i7 3630QM GTX 670MX 8Go RAM SSD 120Go + HDD 750Go Killer WiFi

[Ex-P4G] : ASUS G53SW-SZ143V : Core i7-2630QM GTX 460M 8Go RAM 2 x 500Go Momentus XT (SSH) Blu-Ray

Razer Imperator 2012 - Razer Goliathus Speed - Logitech G35 7.1 - Razer Onza Tournament


#4
Julian93

Julian93

    Geek certifié

  • Membre
  • 1 204 messages
  • LocalisationNão sei amigo !

Salut,

 

Normal Windows 8 n'aime pas beaucoup GTA4 et tu n'est pas le seul à avoir ce problème, seul solution qui fonctionne me semble t-il c'est de mettre gta4 en mode compatibilité windows 7 et forcement faudra passer par l'explorateur ;)


  • 0

#5
Slabre

Slabre

    Touriste

  • Membre
  • 254 messages

On peut pas faire autrement ?

Genre depuis Steam -> clique droit sur GTA 4 -> Definir les options de lancement

Je suis convaincu qu'il existe une commande pour faire ça !


  • 0

[P4G actuel] : MSI GT60 0NC-446FR : Core i7 3630QM GTX 670MX 8Go RAM SSD 120Go + HDD 750Go Killer WiFi

[Ex-P4G] : ASUS G53SW-SZ143V : Core i7-2630QM GTX 460M 8Go RAM 2 x 500Go Momentus XT (SSH) Blu-Ray

Razer Imperator 2012 - Razer Goliathus Speed - Logitech G35 7.1 - Razer Onza Tournament


#6
thehunt33r

thehunt33r

    Grammar Watcher

  • Moderateur
  • 9 167 messages
  • LocalisationRennes

Oui avec --norestrictions

Et pour C++ Redist, il faut démarrer Steam en admin !


  • 0

T4G : Vendu :( (en arrivage : 5820K,32gb DDR4, 970)
P4G : PWNPCS P150SM : 4700MQ, GTX780m, 16gb DDR3, 1*mSATA M500 240GB et 2* Sandisk Ultra Plus 128GB, Ecran mat sous W8.1 Pro X64 & Fedora 21
Tablet4G : Dell Venue 8 Pro : Atom Z3740, 2gb DDR3, Windows 8.1

Server4G : HP N54L Debian
Mechs : IBM Model M 1994 - KBT Poker II Cherry MX Black - CM Storm Novatouch (Topre 45gr)

Spoiler

Spoiler

#7
Slabre

Slabre

    Touriste

  • Membre
  • 254 messages

Alors j'ai essayé de lancé le jeu directement depuis l'explorateur en mode Windows 7, cela ne fonctionne pas.

J'ai essayé avec les astuces de hunter ci-dessus, aucune de celle-ci fonctionne.

 

A rien y comprendre :/


  • 0

[P4G actuel] : MSI GT60 0NC-446FR : Core i7 3630QM GTX 670MX 8Go RAM SSD 120Go + HDD 750Go Killer WiFi

[Ex-P4G] : ASUS G53SW-SZ143V : Core i7-2630QM GTX 460M 8Go RAM 2 x 500Go Momentus XT (SSH) Blu-Ray

Razer Imperator 2012 - Razer Goliathus Speed - Logitech G35 7.1 - Razer Onza Tournament


#8
Slabre

Slabre

    Touriste

  • Membre
  • 254 messages

Petit remontage de sujet !


  • 0

[P4G actuel] : MSI GT60 0NC-446FR : Core i7 3630QM GTX 670MX 8Go RAM SSD 120Go + HDD 750Go Killer WiFi

[Ex-P4G] : ASUS G53SW-SZ143V : Core i7-2630QM GTX 460M 8Go RAM 2 x 500Go Momentus XT (SSH) Blu-Ray

Razer Imperator 2012 - Razer Goliathus Speed - Logitech G35 7.1 - Razer Onza Tournament


#9
EvilSentinel

EvilSentinel

    Touriste

  • Membre
  • 344 messages
  • LocalisationDevant mon écran!

GTA IV fonctionne parfaitement sous Windows 8, et sur Steam. Pour ma part, j'ai eu un soucis avec le paramétrage du pilote nvidia. Il ne faut pas activer le FXAA, sinon le jeu plante au démarrage. Et pas la peine de démarrer le jeu en mode Windows xp ou quoi. J'ai juste eu besoin du -norestrictions, à cause de Optimus et du fait que le jeu ne voit que la HD4000 mais fonctionne sur la GTX680M.


  • 0

MSI GT70 0NE, full HD mat, GTX 680M :tetedemort: GTX 970M, i7-3610QM, 16Go RAM CORSAIR VENGEANCE, 2xSSD 120Go + 750Go 7200trs, Windows 8.1 Pro 64 bits + Media Center.


#10
Slabre

Slabre

    Touriste

  • Membre
  • 254 messages

Ah ok, j'avais mis deux tirets avant "norestrictions" comme l'avait dit hunter.

J'ai donc essayé avec un unique tiret, le jeu se lance bien, et je peux enfin tranquillement modifié les options graphiques.

Cependant, lorsque je clique sur jouer, j'ai toujours cette erreur fatale :/


  • 0

[P4G actuel] : MSI GT60 0NC-446FR : Core i7 3630QM GTX 670MX 8Go RAM SSD 120Go + HDD 750Go Killer WiFi

[Ex-P4G] : ASUS G53SW-SZ143V : Core i7-2630QM GTX 460M 8Go RAM 2 x 500Go Momentus XT (SSH) Blu-Ray

Razer Imperator 2012 - Razer Goliathus Speed - Logitech G35 7.1 - Razer Onza Tournament


#11
EvilSentinel

EvilSentinel

    Touriste

  • Membre
  • 344 messages
  • LocalisationDevant mon écran!

Peut être une réinstallation propre de Windows corrigerait cela?


  • 0

MSI GT70 0NE, full HD mat, GTX 680M :tetedemort: GTX 970M, i7-3610QM, 16Go RAM CORSAIR VENGEANCE, 2xSSD 120Go + 750Go 7200trs, Windows 8.1 Pro 64 bits + Media Center.


#12
Slabre

Slabre

    Touriste

  • Membre
  • 254 messages

Je m'en passerait jute pour GTA 4...


  • 0

[P4G actuel] : MSI GT60 0NC-446FR : Core i7 3630QM GTX 670MX 8Go RAM SSD 120Go + HDD 750Go Killer WiFi

[Ex-P4G] : ASUS G53SW-SZ143V : Core i7-2630QM GTX 460M 8Go RAM 2 x 500Go Momentus XT (SSH) Blu-Ray

Razer Imperator 2012 - Razer Goliathus Speed - Logitech G35 7.1 - Razer Onza Tournament





0 utilisateur(s) li(sen)t ce sujet

0 membre(s), 0 invité(s), 0 utilisateur(s) anonyme(s)